通达信小心涨停指标

休息好了,现在开始继续测评。现在要测的是这个小心涨停指标。

这个名字够让我提精神的。希望结果也一样能让我提精神。

先看源码。


XX1:=CROSS(((-((100)*(HHV(HIGH,IF((IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) – 1),1) > 0.35),6,65)) – CLOSE))/(HHV(HIGH,IF((IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) – 1),1) > 0.35),6,65)) – LLV(LOW,IF((IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) – 1),1) > 0.35),6,65)))))*((DATE < 20070110)),(-2));
A :=MA(CLOSE,26);
UP:=A + 2*STD(CLOSE,26);
LOWER:=A – 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
XX2:=IF(W4 AND COUNT(W4,5)=1,20,0);
VAR1:=EMA(C,2);
VAR2:=EMA(SLOPE(C,21)*20+C,42);
XX3:=CROSS(VAR1,VAR2);
(XX1 AND XX2 AND XX3),COLORLIGREEN;


接下来效果图。


通达信小心涨停指标


看起来都是已经涨停了才出信号,有个小问题是,涨停都能买的到吗。

那我们先假装能买到吧,回测看看。

直接看回测效果吧。先看20周期的。


通达信小心涨停指标

盈亏比一般,但如果再算上涨停买不到的因素,那不理想。

换成1周期试试


通达信小心涨停指标

盈亏比30比14,算不错了。但是,还是刚才的问题,涨停买不到怎么办。

实操还是难。谢谢大家的阅读。

 

END

本测评文章由512168.com通达信指标测评网原创,所有内容仅供学习研究,请勿以此为依据进行股票交易。如若转载,请注明出处:https://www.512168.com/130.html

本测评文章内引用的指标源代码来源于网络,如有侵权请联系删除。

发表评论

电子邮件地址不会被公开。