通达信主力机构主图指标测评

今天拿到了通达信的主力机构主图这个指标。我们来测评一下。看看这个指标怎么样。

首先看一下代码。

——————————————————————————————————————-

品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
股总市值:=ROUND(FINANCE(41)/100000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.008,0.01,0,’基本资料:’),COLORLIBLUE;
DRAWTEXT_FIX(1,0.008,0.05,0,’上市天数:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.09,0,’股东人数:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.13,0,’人均持股:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.17,0,’品种类型:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.25,0,’行业板块:’),COLORLIGREEN;
DRAWTEXT_FIX(品种类型=1,0.066,0.17,0,’沪 深 A 股’),COLORYELLOW;
DRAWTEXT_FIX(品种类型=2,0.066,0.17,0,’ 中 小 板’),COLORYELLOW;
DRAWTEXT_FIX(品种类型=3,0.066,0.17,0,’ 创 业 板’),COLORYELLOW;
DRAWTEXT_FIX(1,0.068,0.25,0,HYBLOCK),COLORYELLOW;{行业板块}
DRAWTEXT_FIX(1,0.068,0.05,0,CON2STR(上市天数,0)),COLORWHITE;{数值}
DRAWTEXT_FIX(1,0.068,0.09,0,CON2STR(股东人数,0)),COLORWHITE;
DRAWTEXT_FIX(1,0.068,0.13,0,CON2STR(人均持股,0)),COLORWHITE;
DRAWTEXT_FIX(1,0.110,0.05,0,’天’),COLORWHITE;{单位}
DRAWTEXT_FIX(1,0.110,0.09,0,’人’),COLORWHITE;
DRAWTEXT_FIX(1,0.110,0.13,0,’股’),COLORWHITE;
DRAWTEXT_FIX(1,0.008,0.21,0,’地区板块:’)COLORLIGREEN;{所属板块}
DRAWTEXT_FIX(1,0.068,0.21,0,DYBLOCK)COLORCYAN;
DRAWTEXT_FIX(1,0.136,0.25,0,’概念板块:’)COLORLIGREEN;
DRAWTEXT_FIX(1,0.196,0.25,0,GNBLOCK)COLORCYAN;
DRAWTEXT_FIX(1,0.008,0.29,0,’风格板块:’)COLORLIGREEN;
DRAWTEXT_FIX(1,0.068,0.29,0,FGBLOCK)COLORCYAN;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
现金负债比:=(FINANCE(25)/FINANCE(15));
主营收入同比:=FINANCE(44);{主营收入同比增长率}
净利润同比:=FINANCE(43);{净利润同比增长率}
DRAWTEXT_FIX(1,0.133,0.01,0,’财务资料(1):’),COLORLIBLUE;
DRAWTEXT_FIX(1,0.133,0.05,0,’净资产收益率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.09,0,’主营业务利润率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.13,0,’现金流动负债比:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.17,0,’主营收入同比:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.21,0,’净利润同比:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.226,0.05,0,STRCAT(VAR2STR(净资收益率,2),’ %’)),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.09,0,STRCAT(VAR2STR(主营利润率,2),’ %’)),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.13,0,CON2STR(现金负债比,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.17,0,STRCAT(VAR2STR(主营收入同比,0),’ %’)),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.21,0,STRCAT(VAR2STR(净利润同比,0),’ %’)),COLORCYAN;
每股收益:=CONST(FINANCE(38));{近期}{每股税后利润}
每股收益年:=CONST(FINANCE(33));
每股净资产:=CONST(FINANCE(34));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
DRAWTEXT_FIX(1,0.285,0.01,0,’财务资料(2):’),COLORLIBLUE;
DRAWTEXT_FIX(1,0.285,0.05,0,’每股收益(近):’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.09,0,’每股收益年:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.13,0,’每股净资产:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.17,0,’每股未分配:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.21,0,’每股公积金:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.386,0.05,1,CON2STR(每股收益,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.09,1,CON2STR(每股收益年,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.13,1,CON2STR(每股净资产,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.17,1,CON2STR(每股未分配,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.21,1,CON2STR(每股公积金,2)),COLORCYAN;
市盈率:=DYNAINFO(39);
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
市净率:=CONST(DYNAINFO(7) / FINANCE(34));
毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);
净利润率:=CONST(FINANCE(30)/FINANCE(20));
DRAWTEXT_FIX(1,0.406,0.01,0,’财务资料(3):’),COLORLIBLUE;
DRAWTEXT_FIX(1,0.406,0.05,0,’市盈率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.09,0,’市销率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.13,0,’市净率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.17,0,’毛利率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.21,0,’净利润率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.489,0.05,1,CON2STR(市盈率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.09,1,CON2STR(市销率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.13,1,CON2STR(市净率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.17,1,CON2STR(毛利率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.21,1,CON2STR(净利润率,2)),COLORCYAN;
经营现金流量:=FINANCE(25)/10000;
资产负债率:=FINANCE(9);
应收帐款:=FINANCE(22)/10000;
DRAWTEXT_FIX(1,0.518,0.01,0,’财务资料(4):’),COLORLIBLUE;
DRAWTEXT_FIX(1,0.518,0.05,0,’资产负债率:’),COLORLIGREEN;
DRAWTEXT_FIX(1,0.636,0.05,1,STRCAT(CON2STR(资产负债率,2),’ %’)),COLORCYAN;
DRAWTEXT_FIX(1,0.518,0.09,0,STRCAT(‘经营现金流量:’,STRCAT(VAR2STR(经营现金流量,0),’ 万元’))),COLORWHITE;
DRAWTEXT_FIX(1,0.518,0.13,0,STRCAT(‘应收帐款:’,STRCAT(VAR2STR(应收帐款,0),’ 万元’))),COLORWHITE;
市值:=STRCAT(STRCAT(‘ 流通市值: ‘,CON2STR((CAPITAL/1000000)*C,2)),’亿元’);
DRAWTEXT_FIX(1,0.598,0.01,0,市值),COLOR0080FF;
AAA5:=STRCAT(‘成交金额:’,CON2STR(DYNAINFO(10)/100000000,2));
AAA6:=STRCAT(‘成交金额:’,CON2STR(DYNAINFO(7)/100000000,2)),’亿元’;
DRAWTEXT_FIX(1,0.728,0.01,0,AAA5),COLORYELLOW;
DRAWTEXT_FIX(1,0.818,0.01,0,AAA6),COLORYELLOW;
AAA7:=STRCAT(‘换手率:’,CON2STR(DYNAINFO(37)*100,2));
AAA8:=STRCAT(‘成交金额:’,CON2STR(DYNAINFO(7)/100000000,2)),’(%)’;
DRAWTEXT_FIX(1,0.868,0.01,0,AAA7),COLORYELLOW;
DRAWTEXT_FIX(1,0.928,0.01,0,AAA8),COLORYELLOW;
STICKLINE(L>REF(H,1) ,REF(H,1),L,4,-1),COLORDF00DF;
STICKLINE(H<REF(L,1) ,REF(L,1),H,4,-1),COLORDFDF00;
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW*0.97,’★大机构进场’),COLORRED;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,’★精准卖’),COLORGREEN;
STICKLINE(L>REF(H,1) ,REF(H,1),L,4,-1),COLORDF00DF;
STICKLINE(H<REF(L,1) ,REF(L,1),H,4,-1),COLORDFDF00;
AA:=LAST(MACD>=REF(MACD,1),3,1);
BB:=MACD<REF(MACD,1);
CC:=LAST(MACD<=REF(MACD,1),3,1);
DD1:=MACD>REF(MACD,1);
SS:=CC AND DD1 AND MACD<0; XX:=AA AND BB AND MACD>0;
A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382; YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4; YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
SMH:=EMA(YCZXH,21);
SML:=EMA(YCZXL,21);
SMJ:=(SML+SMH)/2;
PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55; A1:=EMA(PJ,3),COLOR00400D;
A2:=EMA(PJ,5),COLOR00400D;
A3:=EMA(PJ,7),COLOR00400D;
A4:=EMA(PJ,9),COLOR00400D;
A5:=EMA(PJ,11),COLOR00400D;A6:=EMA(PJ,1),COLOR00400D;
LX:=REF(XJ,1); ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50; DRAWBAND(SMH,RGB(20,220,20),SMH,RGB(0,0,0));
DRAWBAND(SML,RGB(20,220,20),SML,RGB(0,0,0));
DRAWBAND(SMJ,RGB(20,220,20),SMJ,RGB(0,0,0));
DRAWBAND(A6,RGB(250,250,20),A6,RGB(0,0,0)); DRAWBAND(A5,RGB(250,250,20),A5,RGB(0,0,0));
DRAWBAND(A4,RGB(250,250,20),A4,RGB(0,0,0)); DRAWBAND(A3,RGB(250,250,20),A3,RGB(0,0,0));
DRAWBAND(A2,RGB(250,250,20),A2,RGB(0,0,0));


这个指标比较长,我们就不一句句解释了。这个指标有大半代码是显示基本面方面的,可以省去我们查f10的部分时间。

我们先上一张例图。

通达信主力机构主图指标测评

从图上看,“大机构进场”应该是买入时机,“精准卖”应该是卖出时机。

一张图不能说明什么,我们现在回测下历史记录。

为了方便回测,我们在指标尾部加上两行买卖代码。

BUY(FILTER(买=1,5),LOW*0.97);
SELL(FILTER(卖一=1,1),HIGH*1.01);

下面是1999-2020的回测图

通达信主力机构主图指标测评

信号比较多。但胜率接近扔硬币看正反面。如果实操需要过滤信号。

今天这个主力机构主图指标我们就测评到这里,谢谢您的阅读。

 

 

 

END

本测评文章由512168.com通达信指标测评网原创,所有内容仅供学习研究,请勿以此为依据进行股票交易。如若转载,请注明出处:https://www.512168.com/83.html

本测评文章内引用的指标源代码来源于网络,如有侵权请联系删除。

发表评论

电子邮件地址不会被公开。